Installing ybtools on AIX

Follow these steps to install the client tools on an AIX client system:

  1. Download the package for AIX from the SMC. Go to Configure > Drivers and Tools > Client Tools.
  2. Yellowbrick client tools are installed by default at /opt/ybtools and require at least 200MB of free space. Ensure there is enough space on the /opt directory for the installation:
    $ df -g
    Filesystem    GB blocks      Free %Used    Iused %Iused Mounted on
    /dev/hd4           0.09      0.06   36%     2420    15% /
    /dev/hd2           2.06      0.23   89%    37171    40% /usr
    /dev/hd9var        0.19      0.16   17%      950     3% /var
    /dev/hd3           0.22      0.21    2%       33     1% /tmp
    /dev/hd1           0.03      0.03    2%        7     1% /home
    /dev/hd11admin      0.12      0.12    1%        5     1% /admin
    /proc                 -         -    -        -      - /proc
    /dev/hd10opt       0.41      0.03   92%    14452    63% /opt
    /dev/livedump      0.25      0.25    1%        4     1% /var/adm/ras/livedump
    If necessary, increase the amount of space on the /opt directory:
    $ chfs -a size=4G /opt
    Filesystem size changed to 8388608
    $ df -g
    Filesystem    GB blocks      Free %Used    Iused %Iused Mounted on
    /dev/hd4           0.09      0.06   36%     2420    15% /
    /dev/hd2           2.06      0.23   89%    37171    40% /usr
    /dev/hd9var        0.19      0.16   17%      950     3% /var
    /dev/hd3           0.22      0.21    2%       33     1% /tmp
    /dev/hd1           0.03      0.03    2%        7     1% /home
    /dev/hd11admin      0.12      0.12    1%        5     1% /admin
    /proc                 -         -    -        -      - /proc
    /dev/hd10opt       4.00      3.63   10%    14452     2% /opt
    /dev/livedump      0.25      0.25    1%        4     1% /var/adm/ras/livedump
    Note: On RHEL and AIX clients, you can install ybtools in a different preferred location. You do not have to use the default installation directory.
  3. Check the md5sum of the RPM package:
    $ csum -h MD5  ybtools-5.2.4-20201208023004.aix7.1.ppc.rpm
    ebb49ee3ed738d6471cc34bf8fdfd3ea  ybtools-5.2.4-20201208023004.aix7.1.ppc.rpm
  4. Install the ybtools package:
    $ yum install ybtools-5.2.4-20201208023004.aix7.1.ppc.rpm

    where the package name is ybtools-5.2.4-20201208023004.aix7.1.ppc.rpm in this example.

  5. If you see the following error when you run ybsql, set the LIBPATH environment variable:
    $ ybsql --help
    Could not load program ybsql:
        Dependent module libldap.a(libldap-2.4.so.2) could not be loaded.
    Could not load module libldap.a(libldap-2.4.so.2).
    System error: No such file or directory
    $ export LIBPATH="/opt/freeware/lib:/opt/freeware/lib64:/usr/lib64:/usr/lib:/opt/freeware/64/lib:/usr/linux/lib"
    $ ybsql --help
    ybsql is the Yellowbrick Database interactive terminal.
For example, the following installation was run on an AIX 7.1 client system:
$ yum install ybtools-5.2.4-20201208023004.aix7.1.ppc.rpm
Failed to set locale, defaulting to C
AIX_Toolbox                                                                                                      | 2.9 kB  00:00:00
AIX_Toolbox/primary_db                                                                                           | 1.4 MB  00:00:00
AIX_Toolbox_71                                                                                                   | 2.9 kB  00:00:00
AIX_Toolbox_71/primary_db                                                                                        |  23 kB  00:00:00
AIX_Toolbox_noarch                                                                                               | 2.9 kB  00:00:00
AIX_Toolbox_noarch/primary_db                                                                                    |  62 kB  00:00:00
Setting up Install Process
Examining ybtools-5.2.4-20201208023004.aix7.1.ppc.rpm: ybtools-5.2.4-20201208023004.aix7.1.ppc
Marking ybtools-5.2.4-20201208023004.aix7.1.ppc.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package ybtools.ppc 0:5.2.4-20201208023004 will be installed
--> Processing Dependency: libldap.a(libldap-2.4.so.2) for package: ybtools-5.2.4-20201208023004.aix7.1.ppc
--> Running transaction check
---> Package openldap.ppc 0:2.4.48-1 will be installed
--> Processing Dependency: cyrus-sasl >= 2.1.26-2 for package: openldap-2.4.48-1.ppc
--> Processing Dependency: libgcc >= 6.3.0-1 for package: openldap-2.4.48-1.ppc
--> Processing Dependency: libsasl2.a for package: openldap-2.4.48-1.ppc
--> Processing Dependency: libgcc_s.a(shr.o) for package: openldap-2.4.48-1.ppc
--> Running transaction check
---> Package cyrus-sasl.ppc 0:2.1.26-3 will be installed
---> Package libgcc.ppc 0:6.3.0-2 will be installed
--> Finished Dependency Resolution
Dependencies Resolved
...                                                                                                     4.9 MB/s | 6.0 MB     00:01
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : libgcc-6.3.0-2.ppc                                                                               1/4
  Installing : cyrus-sasl-2.1.26-3.ppc                                                                          2/4
  Installing : openldap-2.4.48-1.ppc                                                                            3/4
Group "ldap" does not exist.
  Installing : ybtools-5.2.4-20201208023004.aix7.1.ppc                                                                        4/4
Installed:
  ybtools.ppc 0:5.2.4-20201208023004
Dependency Installed:
  cyrus-sasl.ppc 0:2.1.26-3                         libgcc.ppc 0:6.3.0-2                                  openldap.ppc 0:2.4.48-1
Complete!